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XR, AR, MR or VR ?



AR, MR AND VR

XR: extended reality

Digital environments Digital content on top Digital content interacts
that shut out the real world. of your real world. with your real world.
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https://medium.com/(@yvalendu/what-is-the-difference-between- l1al-reality-augmented-reality-and-mixed-reality-6/d 04c6



https://medium.com/@valendu/what-is-the-difference-between-virtual-reality-augmented-reality-and-mixed-reality-67dfec904c64

AR, MR AND VR

MR blends elements of the real and digital world. In mixed reality, you can
interact and move elements and environments, both physical and virtual.

It offers the possibility of having one foot in the real world and the other in an
imaginary place, breaking down the basic concepts of reality and imagination.

PHYSICAL WORLD DIGITAL WORLD

MIXED REALITY SPECTRUM



https://www.intel.it/content/www/it/it/tech-tips-and-tricks/virtual-reality-vs-augmented-reality.html
https://www.intel.it/content/www/it/it/tech-tips-and-tricks/virtual-reality-vs-augmented-reality.html

MR AND HOLOGRAMS



Holograms

In AR the digital content is displayed on top of visible real environment.

In MR the virtual objects are integrated into and responsive to the real world.
For instance, a virtual ball under the desk would be blocked from a user’s view.

MR takes the best qualities of AR and VR to create an immersive interface that
overlays upon the user’s reality. Rather than displaying simple images like AR, MR
strives to put fully digital objects that are trackable and intractable in the user’s
environment.

This type of rendering demands more processing power than AR.




Holograms

The hologram is a virtual object made entirely of light that partially acts as the
physical (real) object in the world:

Holographic objects can be viewed from different angles and distances, just
like physical objects. They can also interact with the environment (e.g.,
bouncing ball on a table)

However, holograms do not offer any physical resistance when touched or
pushed because they don’t have a mass.




AUGMENTED REALITY



AUGMENTED REALITY

Augmented Reality applications are used to
put additional virtual elements on the real
world.

The virtual elements can include images,
buttons and texts.

The ar app can be used for different purposes,
from entertainment, as video-games, to
business, as an ar app labeling objects or an ar
app supporting marketing.

Image from https://pokemongolive.com/it/
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AUGMENTED REALITY

Augmented Reality app can be developed for mobile phones.
Frameworks:

Android: ARCore 2

iOS: ARKit 3

Unity: ARFoundation # supporting ARCore and ARKit XR plugins, and Windows
XR plugin for HoloLens

Vuforia SDK >, supports both native Android / iOS and Unity AR development as
well as XR development for Hololens

https://www.microsoft.com/it-it/hololens
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AUGMENTED REALITY TYPES

Marker Based
AR

Markerless AR Location Based




MARKER BASED

In Marker based AR (image tracking) a distinctive picture or page should be put in the real

world. The picture is recognized though the device camera (pointing on the picture), and the
additional virtual elements are shown on screen (on top of the image in the real world).

The marker can be anything, as a QR code or a particular Picture, but it should have enough

unique visual points.

Mobile smartphones libraries (as ARCore and ARKit) support image tracking.

https://developers.google.com/ar/develop/augmented-images



https://developers.google.com/ar/develop/augmented-images

MARKER BASED

The images to be recognized are usually stored in a Reference
Image Library structure.

Example from ARFoundation:
https://github.com/Unity-Technologies/arfoundation-
samples/tree/main/Assets/Scenes/ImageTracking

Documentation on image tracking:

https://docs.unity3d.com/Packages/com.unity.xr.arfoundation@4.

2/manual/tracked-image-manager.html

@ Reference Image Library (XR Reference Image Library) L
Open
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https://github.com/Unity-Technologies/arfoundation-samples/tree/main/Assets/Scenes/ImageTracking
https://github.com/Unity-Technologies/arfoundation-samples/tree/main/Assets/Scenes/ImageTracking
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MARKER BASED

Recently also 3D object tracking is available with ARKit:

The structure is the same, a Object Reference Library contains the “object data” of each reference object to be
recognized.

The “object data” is defined as “ARKit Object Reference”, you can scan objects in real world with a iOS mobile
device and then send the resulting file to a PC.

The documentation and the code for the demo application for mobile devices to scan objects and create the ARKit
Object Reference file is available here:

https://developer.apple.com/documentation/arkit/content_anchors/scanning_and_detecting 3d_objects

Prepare to scan Define bounding box Scan Adjust origin Test and Export



https://developer.apple.com/documentation/arkit/content_anchors/scanning_and_detecting_3d_objects

MARKERLESS BASED AR

Markerless based AR eliminates the need for capturing markers to trigger virtual interaction. Applications
based on markerless AR exploit the device’s sensors to gain data useful for AR, as tracking user’s motion/
plane detection ...

Markerless AR merges digital data with real-time and real-world inputs. The technology combines software,
audio, and video graphics with a smartphone’s or headset’s cameras, gyroscope, accelerometer, haptic
sensors, and location services to show virtual object in 3D graphics upon the real world. ARCore and ARKit
offers markerless AR, scanning the environment and creating maps of where to place virtual 3D objects.

Useful links:

ARFoundation Plane Detection Setup
https://docs.unity3d.com/Packages/com.unity.xr.arfoundation@y5. | /manual/features/plane-detection.html

Unity Learn:

https://learn.unity.com/tutorial/configuring-plane-detection-for-ar-foundation/?tab=overview

ARCore
https://developers.google.com/ar/develop/fundamentals

ARKit
https://developer.apple.com/videos/play/wwdc2018/610/
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LOCATION BASED

Location based AR exploit location technologies (GPS data, compass sensors of
mobile phones,...) to place augmented reality content in a specific location.

This type of AR is usually exploited for commercial purposes, cultural heritage (as
interactive maps thet guide people through the city), and gaming ( a famous
example is Pokemon Go).




The ARFoundation GitHub repository collects all samples
(with the corresponding documentation) of ARFoudation,
and it includes Plane Detection, Image Tracking and Object
tracking.

& Unity-Technologies / arfoundation-samples ' public ®Watch 419 ~ % Fork 761 V¢ Star 21k~

<> Code © lIssues 14 1 Pull requests (® Actions 3 Projects 00 wiki @ Security [~ Insights

¥ main ~ ¥ 9branches © 0tags Go to file Add file ~ About

Example content for Unity projects
ankur-unity Update to Unity 2021.2 and AR Foundation 5.0.0-pre.8 31fe4ch on16 Feb ) 796 commits based on AR Foundation

.github Upping the stalebot number of days of inactivity to 30 days before a... 10 months ago [ Readme

&5 View license

7 2.1k stars
Packages Update to Unity 2021.2 and AR Foundation 5.0.0-pre.8 2 months ago ® 419 watching

Assets Update to Unity 2021.2 and AR Foundation 5.0.0-pre.8 2 months ago

ProjectSettings Update to Unity 2021.2 and AR Foundation 5.0.0-pre.8 2 months ago % 761 forks
.gitignore Update packages to 4.1.1 verified 17 months ago
CONTRIBUTING.md Added CONTRIBUTING.md 2 years ago Releases

LICENSE.md Update license copyright to 2020 2 years ago No releases published

o
|
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b
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D
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README.md Update to Unity 2021.2 and AR Foundation 5.0.0-pre.8 2 months ago
Packages

= README.md No packages published

AR Foundation Samples Contribitors @2



https://github.com/Unity-Technologies/arfoundation-samples

WHAT IS ARFOUNDATION

AR foundation allows to work with different AR platforms inside Unity3D

You can install ARFoundation in Unity’s Package Manager directly inside your project.

In addition to that Package, you should install also the Plugin you need, as ARK:it for |OS
apps or ARCore for Android apps development.



ARFOUNDATION SETUP

Go to Window > Package Manager

In the Package Manager select “Packages: Unity Registry” then search the
term AR

Install ARFoundation
Install ARKit or ARCore, depending on your target device
Now open the Scene “SampleARScene”

Add a GameObject > XR > AR Session
AR Session supports enabling and disabling XR on the target device

Add a GameObiject > XR > AR Orrigin

Because AR devices provide their data in "session space”, which is an unscaled
space relative to the beginning of the AR session, the ARSessionOrigin
performs the appropriate transformation into Unity space

https://docs.unity3d.com/Packages/com.unity.xr.arfoundation@4. | /manual/index.html#using-ar-foundation


https://docs.unity3d.com/Packages/com.unity.xr.arfoundation@4.1/manual/index.html

ARFOUNDATION SETUP

Go to File > Build Settings > Switch Platform to the target device
(Android / iOYS)

Now in the Build Settings click on Player Settings to open that panel

In the Player Settings in iOS under the voice “Other Settings” =
“Configuration” check the box corresponding to “Requires ARKit support”

Now Edit > Project Settings > XR Plug-in Management enable the Provider
Plugin setup, i.e. check the box ARKit or ARCore
https://docs.unity3d.com/Packages/com.unity.xr.arfoundation(@4.1/manual/ind
ex.html#provider-plugin-setup

Before building the project in the Player Settings under the voice “Other
Settings” = “Identification” you can change the Bundle Identifier, that should
be a unique identifier of your project.

Now you can build the Project

https://docs.unity3d.com/Packages/com.unity.xr.arfoundation@4. | /manual/index.html#using-ar-foundation


https://docs.unity3d.com/Packages/com.unity.xr.arfoundation@4.1/manual/index.html
https://docs.unity3d.com/Packages/com.unity.xr.arfoundation@4.1/manual/index.html
https://docs.unity3d.com/Packages/com.unity.xr.arfoundation@4.1/manual/index.html

ARFOUNDATION XR SIMULATOR

AR foundation from latest 2022 allows to simulate AR projections on an emulated
environment in your Unity Project using the Editor Run

Enable XR Simulation:
Go to Edit > Project Settings to open the Project Settings window.
In the Project Settings window, select XR Plug-in Management.

Under Plug-in Providers, enable XR Simulation.

https://docs.unity3d.com/Packages/com.unity.xr.arfoundation@5. | /manual/xr-
simulation/simulation.html



https://docs.unity3d.com/Packages/com.unity.xr.arfoundation@5.1/manual/xr-simulation/simulation.html
https://docs.unity3d.com/Packages/com.unity.xr.arfoundation@5.1/manual/xr-simulation/simulation.html

TROUBLESHOOTING

[iIOS] If after the build your project is black, you should enable the Provider
Plugin setup, in the “Project Settings” click on “XR Plug-in Management” then
click on iOS or on Android and respectively check the box ARKit or ARCore (
step | 1)

[Android] If after the build you get an error on ARCore as
“BuildFailedException: ARCore Required apps require a minimum SDK version
of 24.“ or “Failed getting available Android API levels. Could not find Android
SDK Tools.”

You can solve it: Project Settings > Player Settings > Android, under the voice
“Other Settings” = “ldentification” change the “Minimum API Level” to

Nougat level 24

[Android] “BuildFailedException: You have enabled the Vulkan graphics API,
which is not supported by ARCore.”

Under the voice “Other Settings” = “Rendering” change the Graphics APl and
remove Vulkan
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