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WITH UNITY v2020.3.0



OPENXR AND
XR INTERACTION TOOLKIT
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OpenXR provides a single cross-platform, high-performance
API| between applications and all conformant devices.
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IMPORT OPENXR

1. Open the Unity Hub and create a new Unity project

Window Help

. Open the Window > Package Manager

Panels >

Next Window Ctrl+Tab

. In the top-left, select Packages: Unity Registry e T

Layouts >
Collaborate

Asset Store

2
3
4. On the right, search for ‘openxr’ and click on Install button
5

. When the warning pops-up, click on ‘Yes’ /‘ —

Package Manager

‘= Package Manager
+ ~ Packages: Unity Registry v Sort: Name 4 » 1 aopenxr

OpenXR Plugin 102 OpenXR Plugin Warning
Unity Technologies
Version 1.0.3 - March 18, 2021 This project is using the new input system package but
. . the native platform backends for the new input system
are not enabled in the player settings. This means that

OpenXR is an open, royalty-free standard developed by Khronos that no input from native devices will come through.
aims to simplify AR/VR development by allowing developers to target a

wide range of AR/VR devices. Use this plug-in to enable OpenXR in XR Do you want to enable the backends? DOi"g so will

*RESTART* the editor and will *DISABLE* the old

Registry Unity UnityEngine.Input APIs.

Yes No

Last update Mar 14, 12:06 Install ’
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CONFIGURE OPENXR

. Open Edit > Project Settings and select XR Plug-in Management

If there are issues, fix the issues clicking on the Fix All button and
close the issue window

Select XR Plug-in Management

Select OpenXR in ‘Plug-in Providers’

Fix the issues selecting the red (!) and clicking on the Fix All button

Select OpenXR and, in OpenXR Runtime (Editor Instance Only) select Oculus

OpenXR Runtime (Editor Instance Only) | Oculus -

Select OpenXR > Features, you can select your device’s profile in the list: in our case, Oculus
Touch Controller Profile

v Oculus Touch Controller Profile @

Author: Unity _; .

. Close the window d
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XR TOOLKIT

. Open Window > Package Manager

. Search for ‘xr interaction toolkit’ and click on Install button ECEEEESERIEET

. In the pop-up window, select ‘| Made a Backup, Go Ahead!’ IMadeaBackup, Go Ahead!

. On the top-left of the Package Manager window, select Packages: In Project

= Package Manager

v Packages: Unity Registry v S¢

W&~ Unity Registry
In Project

. Select the XR Interaction Toolkit Package, click on ‘Samples’

Samples

Starter Assets
1,62 MB

-

;{_WF:“RV';»: Simulator ‘: .i"-.
. Import the Starter Assets and the XR Device Simulator JJ..'J



XR DEVICE SIMULATOR

= Assets

The XR Device Simulator allows to simulate controllers and HMD B Samples

i 1 XR Interaction Toolki
using mouse and keyboard inputs il NS

[aw Starter Assets
e AffordanceThemes
I Audio

1. In the Project Panel, search for the XR Device Simulator S

prefab and drag it in the Hierarchy M Interactables

Im Teleport

e UI_2D

s UI_3D
Bm XR Origin Pieces
. c I Scripts
2. Press play and you will see the Ul with controls: e X0 Device Smulatr
cripts
*  You can move with WASD Ul

*  You can press grip button with hold [G]

*  You can press trigger button with hold left mouse button

)

b
1)
XR Device Simulator overview | XR Interaction Toolkit | 2.3.0 (unity3d.com)



https://docs.unity3d.com/Packages/com.unity.xr.interaction.toolkit@2.3/manual/xr-device-simulator-overview.html

XR ORIGIN

Right click on the Hierarchy panel to create a 3D Object > Plane, which will be our floor

Delete the Camera GO

1. Right click on the Hierarchy panel and select XR > XR Origin  x > XR Origin (VR)

2. The XR Origin is the center of worldspace in an XR scene; select the XR Origin component of
the XR Origin GO, change the Tracking Origin Mode parameter to Floor:

1. Device: relative to the device

2. Floor: relative to the floor

v XR Origin

Origin Base GameObjec’ @@ XR Origin o ‘,'4
Camera Floor Offset Obj @ Camera Offset

Camera GameObject miMain Camera (Camera) .LJ
Tracking Origin Mode Floor

L:-



XR CONTROLLER

In XR Origin’s children, you can find the LeftHand Controller

and RightHand Controller GOs

« Each one has an XR Contoller Component attached

- Different actions are defined (position, rotation, haptics,

selecting...)

In order to use the default preset from the imported folder
‘Starter Assets’:

1. Click on near the XR Component’s name
2. Select the preset:

1. XRI Default Left Controller for the LeftHand Controller
2. XRI Default Right Controller for the RightHand Controller

-

None

&1 XRI Default Gaze Controller

v XR Controller (Action-based)

Tracking
Update Tracking Type Update And Before Render
Enable Input Tracking v
Position Action
Use Reference
Action
Rotation Action
Use Reference
Action
Tracking State Action
Use Reference

Action

Input
Enable Input Actions v
Select Action

Use Reference

&1 XRI Default Left Controller
&1 XRI Default Right Controller




INPUT ACTION MANAGER

1. Select the XR Origin GO in the Hierarchy
2. You will see an Input Action Manager component attached

3. In Action Assets, you will have the XRI Default Input Actions asset... double left click on it

In the XRI Default Input Action asset all the values from our devices are mapped into all of the
things we can use in our project

XRI Default Input Actions (...

All Control Schemes ¥ Auto-Save
Action Maps + Actions + Action Properties

XRI Head Position + Action

XRI LeftHand Rotation + Action Type Value

XRI LeftHand Interaction Is Tracked 12 .

- ) Control Type Vector 3

XRI LeftHand Locomotion Tracking State 2

XRI RightHand Eye Gaze Position +, Interactions > r 'i‘c,.

XRI RightHand Interaction Eye Gaze Rotation + f
+,

XRI RightHand Locomotion Eye Gaze Tracking State

XRI Ul Processors 2 g l




HANDS MODEL

You can add a model to your hand controllers:

1. Select LeftHand Controller and in XR Controller component, in Model section, add the prefab
you want to use for the left hand in Model Prefab

2. Select RightHand Controller and in XR Controller component, in Model section, add the prefab
you want to use for the right hand in Model Prefab

Model
Model Prefab A XR Controller Left (Transform) O]

Model Parent None (Transform) O]

Animate Model

We will use the XR Controller prefabs available in the: 272
Starter Assets > XR Origin Pieces > Prefabs folder . !



LOCOMOTION AND TELEPORTING




SET UP 1/2

We first need an area where we can teleport:
1. Select the plane GO

2. Add the ‘Teleportation Area’ component

v Teleportation Area

Interaction Manager B XR Interaction Manager (XR Interactic ©®
Interaction Layer Mask Default v
Colliders 0]

We need now to set up a locomotion system:
3. Create a new Empty GO, and call it Locomotion

4. Make it a child of the XR Origin object and reset its Transform component

1
s

D XR Origin Transform

) Locomotion
- e () =

Position



SET UP 2/2

v Locomotion System

5. Select the Locomotion GO, and add to it a
Locomotion System component and select our
XR Origin object in the XR Origin field

Timeout 10
XR Origin B XR Origin (XR Origin)

v Teleportation Provider

System B Locomotion (Locomotion System)
Delay Time 0

6. Add the Teleportation Provider component and
drag the attached Locomotion System

v Snap Turn Provider (Action-based)

Component ]nto the SyStem fleld System B Locomotion (Locomotion System)
Turn Amount 45
Debounce Time 0.5
. . . Enable Turn Left Right v
7. Add the Snap Turn PrOV]der (ACtlon-based) and Enable Turn Around v
drag the attached Locomotion System i G
. . Left Hand Snap Turn Action
component into the System field Use Reference

Action
Right Hand Snap Turn Action
Use Reference

Action




SNAP TURN

. In the Snap Turn Provider component select the Right Hand Snap Turn Action and check Use
Reference

. Click on the circle near the Reference field and search for XRI RightHand Locomotion/Snap Turn

. Select it

Right Hand Snap Turn Action

Use Reference v

Reference 75XRI RightHand Locomotion/Snap Turn (Inpu ®©




If we want to work with teleportation, we need

a Ray Interactor:

1. The default hands of the XR Origin have an
XR Interactor component

RAY INTERACTOR

Duplicate

Delete

2. To create a new Ray Interactor GO: click
with right mouse button in the Hierarcy > S

XR > Raylnteractor

3D Object
Effects
Light
Audio
Video

Ul

@

Device-based

Ray Interactor (Action-based)
Direct Interactor (Action-based)
Gaze Interactor (Action-based)
Socket Interactor

Grab Interactable

Interactable Snap Volume
Interaction Manager
Locomotion System (Action-basec
Teleportation Area
Teleportation Anchor

Ul Canvas

Ul Event System

XR Origin (VR)



CONTINUOUS MOVEMENT

v| Continuous Move Provider (Action-based)

You can have a continuous locomotion
or a COnt]nUOUS turn us.lng: System Bl Locomotion (Locomotion System)

Move Speed 1
Enable Strafe v

- the Continuous Move Provider nable Fly
(Action-based) component Use Gravity v

Gravity Application Mode Attempting Move

Forward Source None (Transform)

* the the Continuous Turn Provider Left Hand Move Action
(Action-based) component Use Reference Y

Reference &5 XRI LeftHand Locomotion/Move (Input Action Reference) ®
Right Hand Move Action
Use Reference

Action

v Continuous Turn Provider (Action-based)

System B Locomotion (Locomotion System)
Tumn Speed 60
Left Hand Turn Action
Use Reference
Action
Right Hand Turn Action
Use Reference v

Reference 65XRI RightHand Locomotion/Turn (Input Action Reference) ©




PHYSICS VR PLAYER

In order to have a physics VR player controller, we need to add to our XR Origin:
« A Character Controller Driver component

« A Character Controller component, which will define the player’s collider

'8! v Character Controller
Slope Limit 45
Step Offset 0.3
Skin Width

Min Move Distance

Center X0
Radius 0.5
Height 2

v Character Controller Driver
#]
Locomotion Provider B Locomotion (Teleportation Provider) ©
Min Height 0]
Max Height Infinity




INTERACTABLE AND INTERACTORS




HOVER, SELECT, ACTIVATE

An interactable is each object you can interact with and use
The interactor is what you use to interact with the interactable: the hands
- HOVER = when your hand touch an interactable

« SELECT = when your hand grab (GRIP) an interactable
« ACTIVATE = when your hand hold (TRIGGER) an interactable



INTERACTOR

We need to add an Interactor component to our hands:

1. Select the LeftHand Controller and [shift] select the RightHand Controller GOs, in the XR Ray
Interactor component click on the trhee points on the right and Remove Component

v| XR Ray Interactor
Reset

Interaction Man4
Remove Component

Interaction Laye

2. Remove also the XR Interactor Line Visual and the Line Renderer components

3. click on ‘Add Component’ and select XR Direct Interactor

4. We also need a collider set to trigger: 9] - TG 21
1. add a Box Collider component for each hand and check ‘Is Trigger’ s Trigger : .1..'



INTERACTABLE

We need to add an Interactable object:

Duplicate
Delete
1. Right click in the Hierarchy panel and select XR > Grab
|nteraCtable Create Empty
3D Object
Effects
Each interactable need a collider, a rigidbody and an XR Grab ;gzt
Interactable component Video
Ul
In the XR Grab Interactable you can change the type of 2R
Camera

movement of the object, in Movement Type field:

* Instantaneous: no collision, no physics

Movement Type Velocity Tracking

* Kinematic: can interact with other objects

* Velocity Tracking: can collide with any object with collider

~ s A w s A ~

Device-based

Ray Interactor (Action-based)
Direct Interactor (Action-based)
Gaze Interactor (Action-based)
Socket Interactor

Grab Interactable €&
Interactable Snap Volume
Interaction Manager
Locomotion System (Action-based)
Teleportation Area
Teleportation Anchor

Ul Canvas

Ul Event System

XR Origin (VR)



INTERACTABLE EVENTS

Interactable Events
First/Last Hover

First Hover Entered (HoverEnterEventArgs)

1. Select the Grab Interactable

Listis Empty

Last Hover Exited (HoverExitEventArgs)

Listis Empty

2. In the XR Grab Interactable component, search for the
I n te racta b le Eve n ts : HHoj:re;mered (HoverEnterEventArgs)

List is Empty

1. Hover: is activated when the interactor enters the collider of the
i nte ractable Hover Exited (HoverExitEventArgs)

List is Empty

2. Select: starts working when we hold an object with the grip button

First/Last Select

3. Activate: starts working when we hold an object with the grip and we T T e T G
pull the trigger button Lstis Empy
Last Select Exited (SelectExitEventArgs)

List is Empty

Select

Select Entered (SelectEnterEventArgs)

List is Empty




ACTIVATE 1/3

Let’s try to add an event, we will use the Activate event

We want to spawn an object when the Grab Interactable GO is grabbed and the trigger button
pressed:

1. In Hierarchy, create a GO with right mouse button > 3D Object > Sphere and add a
Rigidbody component to the Object

2. Add the object into the Project’s Asset folder to transform it into a Prefab and delete it
from the scene

3. Create a script called ‘Objectinteraction’ and open it

4. Create a new public field for the prefab:

public GameObject objectToSpawn;




ACTIVATE 2/3

. Create a new public function to be called when the Activate starts:

public void ActivateStart()

{
GameObject newObject;
newObject = Instantiate(objectToSpawn, new Vector3(e@, ©, ©), new Quaternion(®, ©, 8, ©));

}

. In Unity window, select the Grab Interactable object and attach it the ‘Objectinteraction’
script

. Select the Grab Interactable object and in the Inspector, in the Object Interaction script,
assign the prefab to the Object To Spawn field:

v Object Interaction (Scrip @ 3+ @

o -
o v
Object To Spawn W Sphere 3 i
<)1)




ACTIVATE 3/3

8. In the XR Grab Interactable component, search for the Interactable Events > Activate
9. Click on + on the right, and add the Grab Interactable object in the Object field

10.Select ObjectInteraction > ActivateStart() in function

Activate

Activated (ActivateEventArgs)

Runtime Only v Objectinteraction.ActivateStart
B Grab Interactat @




ACTIVATE EVENT RESULTS

Press play and grab the grabbable object

Then, press trigger button to see the result




BUILD FOR ANDROID




BUILD FOR ANDROID

Make sure that the Android Build Support module is installed, otherwise:

In Unity Hub, select Installs
Select the gear near the Unity version you are using

Select Add Module and install the Android Build Support

Open Edit > Project Settings
Open XR Plug-in Management
Select Android Settings B -nd check ‘Open XR’

Select File > Build > Android

Drag your scene into Scenes In Build and click on Build button
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