SOLAR SYSTEM EXERCISE:
HANDS ON TOGETHER

Corso Realta Virtuale 2024/2025

eleonora.chitti@unimi.it

Code on the laboratory repository Github in the folder
Ex07-01


https://github.com/aislabunimi/courses.vr2025
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UNITY3D WITH XR
ARFOUNDATION




GET STARTED WITH ARFOUNDATION

AR foundation allows to work with different AR platforms inside Unity3D
You can install ARFoundation in Unity’s Package Manager

In addition to that Package, you should install also the Plugin you need, as ARKit for
|OS apps or ARCore for Android apps development.

Supported Platform Packages

The following platform packages and later implement the AR Foundation features indicated above:

Package Name Version

ARCore XR Plugin 4.1

ARKit XR Plugin 4.1

ARKit Face Tracking 4.1

Magic Leap XR Plugin 6.0 .‘
Windows XR Plugin 5.0 _J i

https://docs.unity3d.com/Packages/com.unity.xr.arfoundation(@4.1/manual/index.html#using-ar-foundation



https://docs.unity3d.com/Packages/com.unity.xr.arfoundation@4.1/manual/index.html

WHAT TO DO NOW

At this point we have modeled a Solar System in a Unity 3D Scene named
SampleScene.

Now we will use the same assets to create the XR version, then we will build it
for |OS with ARKit + ARFoundation
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CREATE A NEW SCENE

Create a new scene: File > New Scene , save it and v o Al Shaded
call it SampleSceneAR Bl s aiplasconeah 5

9 Main Camera Set Active Scene

W@ venus

. . §#@ uranus Save Scene
Go to Assets folder and right click on the =
.. > '!! Save Scene As

SampleScene -> select Open Scene Additive §# neptune Save Al

W# mercury ave

W@ mars

@ sun Unload Scene
From the SampleScene, copy all the planets Game Objects E,: e Remaye Scene
and the SetupScene Game Object &) Directional Light

> % gz;uvpasscene Select Scene Asset

0 EventSystem
Right click on the SampleScene -> select Unload Scene

Paste the Game Objects in the SampleSceneAR

Right click on the SampleScene -> select Remove Scene

Add New Scene

GameObject




ADD ARFOUNDATION PACKAGE

Go to Window > Package Manager

In the Package Manager select “Packages: Unity Registry” then
search the term AR

Install ARFoundation

Install ARKit or ARCore, depending on your target device (for this
exercise we will install ARKit)
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SETUP THE SampleSceneAR

Now in the SampleSceneAR delete
the Main Camera

Add a GameObject > XR >AR
Session

AR Session supports enabling and
disabling XR on the target device

Add a GameObject > XR > AR
Origin

Because AR devices provide their
data in "session space”, which is an
unscaled space relative to the
beginning of the AR session,

the ARSessionOrrigin performs the
appropriate transformation into
Unity space

Hierarchy

v | All

& SampleSceneAR
& Directional Light
@ sun
W@ neptune
4@ venus

> @ saturn
4@ mercury
W@ earth
@ mars
W@ jupiter
i@ uranus
&) SetupScene
2 AR Session

> ) AR Session Origin

BIDICEE

Q’)O‘Hﬁ}lvl‘k“llv‘Gizmos\

Save Scene

Save Scene As

Select Scene Asset
Add New Scene

GameObject

Project

>

Create Empty
3D Object
Effects

Light

Audio

Video

Ul

XR

N Y VvV VWV VWV VvV Vv

Camera

v

Convert Main Camera To XR Rig
AR Session Origin
AR Session
AR Default Point Cloud

(v Favorites
O, All Materials
O, All Models
O, All Prefabs

Assets > Scenes

Vo W

AR Default Plane
AR Default Face

F




BUILD SETUP

Go to File > Build Settings

Click on the button “Add Open Scenes”

Click on the target device iOS and then

click on the button “Switch Platform,” wait M

for Unity to switch
(it may take some minutes)

Now in the Build Settings click on the
button “Player Settings” to open the
corresponding panel

L NON
Build Settings

Build Settings

Scenes In Build

~ Scenes/SampleSceneAR

Platform

;] PC, Mac & Linux Standalone

\-1_3 |ﬁ| Android
% WebGL

tvOS tvOS
=ra PS4

f;\ Xbox One

\ Playrer Settings...

0
‘B Add Open Scenes
iOS ios
Run in Xcode v.12.4 / Applications /X v
Run in Xcode as Release v

Symlink Unity libraries
Development Build
Autoconnect Profiler
Deep Profiling

Script Debugging
Scripts Only Build

Compression Method Default

blut Unity Cloud Build

SW|tch Platform Build And Run

https://docs.unity3d.com/Packages/com.unity.xr.arfoundation(@4. 1 /manual/index.html#using-ar-foundation
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https://docs.unity3d.com/Packages/com.unity.xr.arfoundation@4.1/manual/index.html

PLAYER SETTINGS SETUP

In the Player Settings click on iOS

under the voice “Other Settings” = “Configuration” check the box
corresponding to “Requires ARKit support”

( Player Settings are inside the Project Settings window, you can also go to Player
Settings by click on Edit > Project Settings then click on “Player” )

-
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https://docs.unity3d.com/Packages/com.unity.xr.arfoundation(@4.1/manual/index.html#using-ar-foundation
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£ Project Settings

i ) e | accomn - luyers - [[Loyon |

Adaptive Performance
Audio

Editor

Graphics

Input Manager
Package Manager
Physics

Physics 2D

Player

Preset Manager
Quality

Scene Template
Script Execution Order

¥ Services

Ads
Analytics
Cloud Build
Cloud Diagnostics
Collaborate
In-App Purchasing
Tags and Layers
TextMesh Pro
Time
Timeline
Version Control
¥ XR Plug-in Management
ARKit

Player

Default Cursor

Cursor Hotspot

X0

(=] i0S

Settings foriOS

‘ » lcon

‘ » Resolution and Presentation

> Splash Image

‘ » Debugging and crash reporting

¥ Other Settings
Rendering
Color Space*

Gamma

\ Color Gamut*

aroe

Metal API Validation*
Metal Write-Only Backbuffer

ey N, WO Oy VO oV PV, W o

s

| @ nspector | & Project Settings

Scrolling down

with the mouse

Script Execution Order
¥ Services
Ads
Analytics
Cloud Build
Cloud Diagnostics
Collaborate
In-App Purchasing
Tags and Layers
TextMesh Pro
Time
Timeline
Version Control
¥ XR Plug-in Management
ARKit

1_0

Adaptive Performance P|ayer
Audio Tt s
Editor iOS Provisioning Pro
Graphics Profile ID:
Input Manager

Profile Type:
Package Manager DG S
Physics Configuration
Physics 2D Scripting Backend

Api Compatibility Level*

Preset Manager P 2 gy
Quality C++ Compiler Configuration
Scene Template Use incremental GC

Camera Usage Description*

Location Usage Description*
Use on-demand resources*
Accelerometer Frequency*
Mute Other Audio Sources*

Automatic

IL2CPP
.NET Standard 2.0

Release
v

Required for augmented reality support.

Microphone Usage Description*

60 Hz

is off.

Prepare iOS for Recording

Requires Persistent WiFi*
Allow downloads over HTTP
» Supported URL schemes*
Target Device

Target SDK

Target minimum iOS Version
Enable ProMotion Support
Requires ARKit support

Architecture

Active Input Handling*

Script Compilation

‘ ‘ Audio input from Bluetooth microphones is not supported when Mute Other Audio Sources

Force iOS Speakers when Recording

(nonsecure)* v

iPhone + iPad

Device SDK

11.0

v
v

» Defer system gestures on edges
Hide home button on iPhone X

Render Extra Frame on Pause

Enable Custom Background Behaviors

ARMB4
Input Manager (Old)

(et v v b ot~




XR PLUGIN MANAGEMENT SETUP

0 Inspector £ Project Settings |

Q
Adaptive Performance XR Plug-in Management 7_1
Audio
oS { iy

Now in the Project Settings click on Editor
“XR P M . Graphics J :
ug-in Management E::E:gzn&gi;ger Initialize XR on Startup v
Physics

Plug-in Providers @

Click on iOS (or Android depending on  pnysics 20

. . . . Player v ARKit R
target device, in this exercise we are Preset Manager 7 ?

g g Quality
using |OS) Scene Template
Script Execution Order Information about configuration, tracking and migration can be found below.
1 H v Services View D tati
Enable the Provider Plugin setup, e lew Documentation
i 3 . Analyti
checking the box ARKit for iOS A
1 Cloud Di i
(ARCore for Android) Cloud Diagnostics

https://docs.unity3d.com/Packages/com. | ragsamiavers

unity.xr.arfoundation@4. | /manual/inde Textiesh Pro
x.html#provider-plugin-setup ~ Jimeline

XR Plug-in Management

Al ;

https://docs.unity3d.com/Packages/com.unity.xr.arfoundation(@4. 1 /manual/index.html#using-ar-foundation
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BUILD THE PROJECT

(Optional) Before building the project in the _ms;ngs b

Scenes In Build

Player Settings under the voice “Other Settings” LB
—> “ldentification” you can change the Bundle
|dentifier;, that should be a unique identifier of

0

your project.

Platform

@ PC, Mac & Linux Standalone

Now you can go to Build Settings and click on o

i i
BU|Id |ﬁ| Android
B wevot
tvOS tvOS

=ra PS4

l;\ Xbox One

Player Settings...

iOS ios

Run in Xcode

Run in Xcode as
Symlink Unity libraries
Development Build
Autoconnect Profiler
Deep Profiling

Script Debugging
Scripts Only Build

Compression Method

Add Open Scenes

v.12.4 / Applications /X v
Release v

Default v

Learn about Unity Cloud Build

Build Build And Run

Y —

https://docs.unity3d.com/Packages/com.unity.xr.arfoundation(@4.1/manual/index.html#using-ar-foundation
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BUILD THE PROJECT

Build iOS

M~ %~ @@vo Q
Now a Save Panel appears, create a folder called vostorday oy oty
Builds inside the root folder called “exe-solar-sys” = exe-solar-sys . B9 Builds ' CIB
and inside it create another folder, we will call it Piayiaus 7 Bave W IR ) ’
. < Yesterda
“version0” : | ' .
]
this folder will be the one to be opened with Xcode. Sk isasts > 1
T Library >
™7 Logs >
23 obj > |
7 Packages >
77 ProjectSettings >
7 UserSettinas > i
New Folder Cancel i

https://docs.unity3d.com/Packages/com.unity.xr.arfoundation(@4.1/manual/index.html#using-ar-foundation
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IF YOU WANT TO BUILD WITH ANDROID

With Unity targeting an Android, you can press the
button Build to directly create the .apk to be installed
into your mobile device.

Otherwise, you can decide to export it as Gradle
Project.

This second option is very similar to the step 26 :
you need to create a Builds folder and then another
folder as versionO inside it, and the version0O folder
will be the one you will need to open with Android
Studio.

| _JON

Build Settings

<

Build Settings

Scenes In Build

v Scenes/SampleSceneAR

Platform

;] PC, Mac & Linux Standalone
i0S ios

|ﬁ| Android

% WebGL

twvOS tvOS

=ra PS4

!;\ Xbox One

Player Settings...

Add Open Scenes

F- .
|'| Android

Texture Compression Don't override
ETC2 fallback 32-bit

Export Project

Symlink Sources

Build App Bundle (Google Play
Create symbols.zip

Run Device Default device ¥ = Refresh

Development Build
Autoconnect Profiler
Deep Profiling
Script Debugging

Scripts Only Build Patch  Patch And Run

Compression Method Lz4 v

Learn about Unity Cloud Build

Export Build And Run

https://docs.unity3d.com/Packages/com.unity.xr.arfoundation@4. | /manual/index.html#using-ar-foundation
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XCODE FOR I0OS

To build an Xcode project for development you need a simple Apple ID (it is the
free personal ID you use to login in the smartphone or on iCloud)
https://support.apple.com/it-it/apple-id

The free Apple ID can be used only to build TEST APP on your iOS device, it
cannot be used to load on Apple Store (it needs a billing account)

To build the TEST app on the iOS target device remember that:
the Apple ID on Xcode should be the same ID on the iOS device

on the iOS device you can install no more than 3 different TEST apps

A



https://support.apple.com/it-it/apple-id

XCODE FOR I0OS

Once the build has done you can open the version0 folder ® @ &

with Xcode
In the menu click on Xcode > Preferences

Click on Accounts area and click on +

From the popup choose Apple ID, then click on Confirm and
perform the login with your Apple ID credentials

Select the type of account you would like to add:

|

=

=l

s Navigation

Q)] Apple ID
Apple 1D:
Description:

Accounts

e »® o

Themes Text Editing Key Bindings Source C

Team Role

Xcode Server

Bitbucket Cloud

Bitbucket Server

Download Manual Profiles

Cancel

Manage Certificates..




XCODE FOR IOS

Now click on the Root of the
Project (the one usually called
Unity-iPhone)

Click on “Signing & Capabilities”

check the box “Automatically
manage signing” a popup will
appear, click on the button
“Enable Automatic”

Now at the voice Team, click on
“none”’, and from the menu
select your ID

Xcode File Edit View Find

Navigate  Editor Product Debug Source Control Window Help

v

eoe M >

+

H T a A e gD B

ki globalgamemanagers
ki globalgamemanagers.assets
L levelO

> [0 Managed

> [0 Resources
% RuntimelnitializeOnLoads.js...
% ScriptingAssemblies.json
k& sharedassets0.assets
sharedassets0.assets.resS
kd unity default resources
> B3 UnitySubsystems

—_
& Images.xcassets

~ 7 MainApp

m main.mm

v [ Classes

> 77 PluginBase
>Eu

> 7 Unity
CrashReporter.h

m CrashReporter.mm

=

iPhone_Sensors.h
iPhone_Sensors.mm
main.mm
PLCrashReporter.h
Prefix.pch

s (3 3 =

UndefinePlatforms.h
RedefinePlatforms.h
Preprocessor.h
UnityAppController.h
UnityAppController.mm
UnityAppController+Render...
UnityAppController+Render...
)

= (2= = = |

ﬂ Unity-iPhone ) . iPad di Aislab Indexing | Processing files [

B <

B Unity-iPhone

E’ Unity-iPhone.xcodeproj

I} General Signing & Capabilities Resource Tags Info Build Settings Build Phases Build Rules

PROJECT

Profiling

Automatically manage signing ?

Team None

+ Capability m Release Running Debug

Pe (it
& Unity-iPhone signing
TARGETS
n Unity-iPhone
Unity-iPhone Tests

54 UnityFramework

Bundle Ide| m.DefaultCompany.exe-solar-sys

Provisiong rofile Xcode Managed Profile
Certificate Apple Development
Status @) Signing for "Unity-iPhone" requires a
development team.

Select a development team in the Signing &
Capabilities editor

+ - @

© B © Q@
< A > Identity and Type
Name Unity-iPhone

Location

Project Document
Project Format Xcode 3.2-compatible
Organization

Class Prefix

Text Settings

Indent Using  Spaces

Widths 47
Tab Indent

Wrap lines

i
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XCODE FOR IOS

.

@ Xcode File Edit View Find

Navigate

Editor ct Debug Source Control Window Help

eoe M >
= N I QA G

Now connect your device, it
should automatically appear.
(If it does not appear
automatically you can click on
“Any Device” to open the
menu and see the available
devices, sometimes if the device
is not appearing you can just
unplug it, unlock the device and
then plug it again)

~ Bl Data

ki boot.config

L levelO
> [0 Managed

UnitySubsystems
&F Images.xcassets
MainApp
m main.mm
" Classes
> 77 PluginBase
>Eu
> 7 Unity
CrashReporter.h
m CrashReporter.mm

=

Now you can Run it

iPhone_Sensors.h
iPhone_Sensors.mm
main.mm
PLCrashReporter.h
Prefix.pch
UndefinePlatforms.h
RedefinePlatforms.h
Preprocessor.h
UnityAppController.h

= (3 3 |=

UnityAppController.mm
UnityAppController+Render...

ENERENERENERNE

UnityAppController+Render...

+ (& 0]=|

B unity-iphone ) [l iPad di Aislab

Indexing | Processing files 6

g8 < [ unity-iPhone.xcodeproj
B Unity-iPhone
In} General Signing & Capabilities Resource Tags Info Build Settings Build Phases Build Rules
PROJECT + Capability m Release Profiling orRunning Debug
Pe (it
& Unity-iPhone signing
TARGETS . A
Automatically manage signing
ﬂ Unity-iPhone
Unity-iPhone Tests
Team None

+

3 UnityFramework
Bundle Identifier com.DefaultCompany.exe-solar-sys

Provisioning Profile Xcode Managed Profile

Signing Certificate Apple Development

Status € Signing for "Unity-iPhone" requires a
development team.
Select a development team in the Signing &

Capabilities editor

© B © Q@
< 4 > Identity and Type
Name Unity-iPhone

Location

Project Document

Project Format Xcode 3.2-compatible
Organization

Class Prefix

Text Settings

Indent Using Spaces

Widths 43
Tab Indent

Wrap lines
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TROUBLESHOOTING

[iOS / Android] If after the build, you run it on your device and the screen is black:
you should enable the Provider Plugin setup, in the “Project Settings” click on “XR Plug-in Management”
then click on iOS or on Android and respectively check the box ARKit or ARCore ( step I I)

[Android] If after the build you get an error on ARCore as “BuildFailedException: ARCore Required apps
require a minimum SDK version of 24.“ or “Failed getting available Android API levels. Could not find
Android SDK Tools.”

You can solve it: Project Settings > Player Settings > Android, under the voice “Other Settings” =
“Identification” change the “Minimum API Level” to Nougat level 24

[Android] “BuildFailedException: You have enabled the Vulkan graphics API, which is not supported by
ARCore.”

Under the voice “Other Settings” = “Rendering” change the Graphics APl and remove Vulkan.

If you can not findVulkan in Rendering: In BuildSettings -> Project settings -> Player -> Other settings: disable the
Auto Graphics APl checkbox and remove Vulcan from the Graphics APIs list
https://forum.unity.com/threads/you-have-enabled-the-vulkan-graphics-api-which-is-not-supported-by-
arcore.896741/



https://forum.unity.com/threads/you-have-enabled-the-vulkan-graphics-api-which-is-not-supported-by-arcore.896741/
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