SOLAR SYSTEM EXERCISE:
HANDS ON TOGETHER

Corso Realta Virtuale 2023/2024

eleonora.chitti@unimi.it

Code on the laboratory repository Github in the folder
Ex07-01



https://github.com/aislabunimi/courses.vr2022
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UNITY3D WITH XR

ARFOUNDATION




GET STARTED WITH ARFOUNDATION

AR foundation allows to work with different AR platforms inside Unity3D

You can install ARFoundation in Unity’s Package Manager
In addition to that Package, you should install also the Plugin you need, as ARKit for
IOS apps or ARCore for Android apps development.

Supported Platform Packages

The following platform packages and later implement the AR Foundation features indicated above:

Package Name Version

ARCore XR Plugin 4.1

ARKit XR Plugin 4.1

ARKit Face Tracking 4.1

Magic Leap XR Plugin 6.0 ‘,
Windows XR Plugin 5.0

https://docs.unity3d.com/Packages/com.unity.xr.arfoundation@4. | /manual/index.html#using-ar-foundation



https://docs.unity3d.com/Packages/com.unity.xr.arfoundation@4.1/manual/index.html

WHAT TO DO NOW

At this point we have modeled a Solar System in a Unity 3D Scene named
SampleScene.

Now we will use the same assets to create the XR version, then we will build it
for 10S with ARKit + ARFoundation
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CREATE A NEW SCENE

Create a new scene: File > New Scene , save it and
call it SampleSceneAR

Go to Assets folder and right click on the
SampleScene -> select Open Scene Additive

From the SampleScene, copy all the planets Game Objects
and the SetupScene Game Object

Right click on the SampleScene -> select Unload Scene

Paste the Game Objects in the SampleSceneAR

Right click on the SampleScene -> select Remove Scene
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Save Scene
Save Scene As
Save All

Remove Scene

Select Scene Asset

Add New Scene

GameObject

Unload Scene
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ADD ARFOUNDATION PACKAGE

Go to Window > Package Manager

In the Package Manager select “Packages: Unity Registry” then
search the term AR

Install ARFoundation

Install ARKit or ARCore, depending on your target device (for this
exercise we will install ARKit)
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SETUP THE SampleSceneAR

|27. Now in the SampleSceneAR delete
the Main Camera

| 3. Add a GameObject > XR > AR
Session
AR Session supports enabling and
disabling XR on the target device

| 4. Add a GameObject > XR > AR
Origin
Because AR devices provide their
data in "session space", which is an
unscaled space relative to the
beginning of the AR session,
the ARSessionOrigin performs the
appropriate transformation into
Unity space
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BUILD SETUP

® 0 Build Settings
I5. Go to File > Build Settings Build Settings
Scenes In Build
v Scenes/SampleSceneAR 0
| 6. Click on the button “Add Open Scenes”
N
\ Add Open Scenes
Platform

|7. Click on the target device iOS and then 0 Pe, Mac & Linux Stncaone. ] 108 108

click on the button “Switch Platform,’” wait /‘m
. . Run in Xcode v.12.4 / Applications /X v
for Unlty to switch Run in Xcode as Release v

\ |i| Android
. a Symlink Unity libraries [ ]
(it may take some minutes) -1'3 e N oy A
E WebGL
Autoconnect Profiler
tvOS tvOS Deep Profiling
Script Debugging
=ra PS4 Scripts Only Build

| 8. Now in the Build Settings click on the

I;\ Xbox One

button “Player Settings” to open the

corresponding panel Compression Method Default
| X37)
l ut Unity Cloud Build
s Player Settings... __Switch Platform | Build And Run

https://docs.unity3d.com/Packages/com.unity.xr.arfoundation@4. | /manual/index.html#using-ar-foundation



https://docs.unity3d.com/Packages/com.unity.xr.arfoundation@4.1/manual/index.html

PLAYER SETTINGS SETUP

In the Player Settings click on iOS

under the voice “Other Settings” = “Configuration” check the box
corresponding to “Requires ARKit support”

( Player Settings are inside the Project Settings window, you can also go to Player
Settings by click on Edit > Project Settings then click on “Player” )
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Scrolling down with the mouse

NET Standard 2.0 v

[

Required for augmented reality support.

iPhone + iPad
Device SDK
1.0

[ ]
[ ]
[ ]

Input Manager (Old) v




XR PLUGIN MANAGEMENT SETUP

2 1. Now in the Project Settings click on
“XR Plug-in Management”

22. Click on iOS (or Android depending on
target device, in this exercise we are
using iOS)

23. Enable the Provider Plugin setup,
checking the box ARKit for iOS
(ARCore for Android)
https://docs.unity3d.com/Packages/com.
unity.xr.arfoundation@4. | /manual/inde
x.html#provider-plugin-setup ﬂ

https://docs.unity3d.com/Packages/com.unity.xr.arfoundation@4. | /manual/index.html#using-ar-foundation
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BUILD THE PROJECT

(@) Build Settings
24. (Optional) Before building the project in the ::11:53::fm :
Player Settings under the voice “Other Settings” e g
—> “Ildentification” you can change the Bundle
Identifier, that should be a unique identifier of
Add Open Scenes

)’O U r p I"O] eCt- Platform

. . . PC, Mac & Linux Standalone iOS ios
25. Now you can go to Build Settings and click on b
Run in Xcode 'v.12.4 / Applications /X v

BLI ild 2 ) Run in Xcode as ‘Release v
[ ) el Symlink Unity libraries )

Development Build
Autoconnect Profiler

E WebGL

tvOS tvOS Deep Profiling
Script Debugging
=ra PS4 Scripts Only Build

!;\ Xbox One

Compression Method ' Default ¥

Learn about Unity Cloud Build
Player Settings... Build Build AndRun |

T ———————

https://docs.unity3d.com/Packages/com.unity.xr.arfoundation@4. | /manual/index.html#using-ar-foundation
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BUILD THE PROJECT

Build iOS

m~v & v v 8 Qa
Now a Save Panel appears, create a folder called B oy oy
Builds inside the root folder called “exe-solar-sys” R > £ Builds o =
and inside it create another folder, we will call it Previous 7 Days i Teme ’
Y . ’ < Yesterday
version0” :

this folder will be the one to be opened with Xcode. B Assets ’

T2 Library >

7 Logs >

3 obj >

T Packages >

T ProjectSettings >

T3 UserSettinas >

New Folder Cancel

https://docs.unity3d.com/Packages/com.unity.xr.arfoundation@4. | /manual/index.html#using-ar-foundation
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IF YOU WANT TO BUILD WITH ANDROID

With Unity targeting an Android, you can press the
button Build to directly create the .apk to be installed
into your mobile device.

Otherwise, you can decide to export it as Gradle
Project.

This second option is very similar to the step 26 :
you need to create a Builds folder and then another
folder as versionO inside it, and the versionO folder
will be the one you will need to open with Android
Studio.

Build Settings

-

Build Settings

Scenes In Build

v Scenes/SampleSceneAR

Platform

l; PC, Mac & Linux Standalone
iOS ios

|i| Android

g WebGL

tvOS tvOs

=ra PS4

fa) Xbox One

Player Settings...

Add Open Scenes

=
|'| Android

Texture Compression Don't override
ETC2 fallback 32-bit
Export Project

Symlink Sources
Build App Bundle (Google Play
Create symbols.zip

Default device v | Refresh

Run Device
Development Build
Autoconnect Profiler

Deep Profiling
Script Debugging

Scripts Only Build Patch = Patch And Run

Compression Method Lz4 v

Learn about Unity Cloud Build

Export Build And Run

v
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XCODE FOR IOS

To build an Xcode project for development you need a simple Apple ID (it is the
free personal ID you use to login in the smartphone or on iCloud)
https://support.apple.com/it-it/apple-id

The free Apple ID can be used only to build TEST APP on your iOS device, it
cannot be used to load on Apple Store (it needs a billing account)

To build the TEST app on the iOS target device remember that:
the Apple ID on Xcode should be the same ID on the iOS device

on the iOS device you can install no more than 3 different TEST apps

-



https://support.apple.com/it-it/apple-id

XCODE FOR IOS

Once the build has done you can open the versionO folder
with Xcode

In the menu click on Xcode > Preferences

Click on Accounts area and click on +

From the popup choose Apple ID, then click on Confirm and
perform the login with your Apple ID credentials

ece Accounts

@& @ £ © L o () =)

General Accounts Behaviors Navigation Themes TextEditing Key Bindings Source Control Components Locations ~ Server & Bots

)] Apple ID
Apple ID:
_ = -
Description:
Team Role

Q Download Manual Profiles ~ Manage Certificates...
-

Select the type of account you would like to add:

Apple ID |

(e Xcode Server
&y Bitbucket Cloud

i“l Bitbucket Server

Cancel Continue




XCODE FOR IOS

Now click on the Root of the
Project (the one usually called
Unity-iPhone)

Click on “Signing & Capabilities”

check the box “Automatically
manage signing” a popup will
appear, click on the button
“Enable Automatic”

Now at the voice Team, click on
“none”, and from the menu
select your ID

@ Xcode File Edit View Find

Navigate  Editor

Product

Debug  Source Control

Window  Help

eoe M |

= = QA o g D B
v [ Unity-iPhone
v [ Data

L& boot.config
k& globalgamemanagers

4 globalgamemanagers.assets
L& levelo

> B3 Managed

> [ Resources
% RuntimelnitializeOnLoads.js...
6 ScriptingAssemblies.json
L sharedassets0.assets

sharedassets0.assets.resS

L unity default resources

> B3 UnitySubsystems

Images.xcassets

MainApp
m main.mm
v [ Classes
> 77 PluginBase
>Eu
> 7 Unity
CrashReporter.h

ENE:

CrashReporter.mm

>

iPhone_Sensors.h
iPhone_Sensors.mm

3 (3

main.mm
PLCrashReporter.h
Prefix.pch

<
=

UndefinePlatforms.h
RedefinePlatforms.h
Preprocessor.h
UnityAppController.h
UnityAppController.mm

3 = [= [=

3

>

UnityAppController+Render...

3

UnityAppController+Render...
(O]

Unity-iPhone ) [l iPad di Aislab

B <

[E unity-iPhone

1] General

PROJECT
[ unity-iPhone
TARGETS
B unity-iPhone
[ Unity-iPhone Tests
[ UnityFramework

+ - ©

Indexing | Processing files

B unity-iPhone.xcodeproj

Signing & Capabilities

Resource Tags  Info

Build Settings Build Phases

+ capabity ([ ] Release

signing

Certificate

Status

Profiling ing  Debug

Automatically manage signing ?

None ]

Im.DefaultCompany.exe-solar-sys
Xcode Managed Profile

Apple Development

© Signing for "Unity-iPhone* requires a
development team.

Select a development team in the Signing &
Capabilities editor.

Build Rules

® & OO0
< > | Identity and Type
Name Unity-iPhone

Location

Project Document

Project Format Xcode 3.2-compatible

Organization

Class Prefix

Text Settings
Indent Using  Spaces

Widths 4
Tab

Wrap lines

Indent

4

n
T ——

o @
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XCODE FOR IOS

Now connect your device, it
should automatically appear.
(If it does not appear

automatically you can click on

“Any Device” to open the
menu and see the available

devices, sometimes if the device

is not appearing you can just

unplug it, unlock the device and

then plug it again)

Now you can Run it

File  Edit

Xcode View Find Navigate Editor t Debug Source Control Window Help

eoe [

Unity-iPhone ) [l] iPad di Aislab  Indexing | Processing files

I Q A & D 3 8 <

[ unity-iPhone

Unity-iPhone.xcodeproj

v @ Unity-iPhone

6 RuntimeffiitializeOnLoads.js...

6 ScriptiffgAssemblies.json

[ UnityFramework
Bundle Identifier com.DefaultCompany.exe-solar-sys

& shaggfiassets0.assets Provisioning Profile Xcode Managed Profile

edassets0.assets.resS Signing Certificate Apple Development
ity default resources

UnitySubsystems Status @ Signing for "Unity-iPhone" requires a
levelopment team.
Select a development team in the Signing &
Capabilities editor.

@ 'mages.xcassets
MainApp

m main.mm

T Classes

> 7 PluginBase
>E U

> 77 Unity
CrashReporter.h

L]
-
v

CrashReporter.mm
iPhone_Sensors.h
iPhone_Sensors.mm
main.mm
PLCrashReporter.h

+ Prefix.pch

ENENENENENE"

h UndefinePlatforms.h
h RedefinePlatforms.h
h Preprocessor.h
> h  UnityAppController.h
m UnityAppController.mm
h UnityAppController+Render...
m UnityAppController+Render...

A+ oH + - @®

v B3 Data D General  Signing & Capabilities ~ Resource Tags  Info  Build Settings  Build Phases
i boot.config PROJECT + capabilty (D Release Profiling Running  Debug
L globalgamemagigers B
Unity-iPhone -
& globalgamemghagers.assets = v Signing
. TARGETS
& levelo Automatically manage signing
> B3 Managed B unity-iPhone
> B3 Resourceg 7] Unity-iPhone Tests
Team None 9

Build Rules

® B OO0

< > | Identity and Type

|

Name Unity-iPhone

Location
-
>
Project Document
Project Format  Xcode 3.2-compatible | n
Organization

Class Prefix

Text Settings
Indent Using Spaces [}

Widths 43 4
Tab Indent

Wrap lines
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TROUBLESHOOTING

[iOS / Android] If after the build, you run it on your device and the screen is black:
you should enable the Provider Plugin setup, in the “Project Settings” click on “XR Plug-in Management”
then click on iOS or on Android and respectively check the box ARKit or ARCore ( step I I)

[Android] If after the build you get an error on ARCore as “BuildFailedException: ARCore Required apps
require a minimum SDK version of 24.* or “Failed getting available Android API levels. Could not find
Android SDK Tools.”

You can solve it: Project Settings > Player Settings > Android, under the voice “Other Settings” 2>
“Identification” change the “Minimum API Level” to Nougat level 24

[Android] “BuildFailedException:You have enabled the Vulkan graphics API, which is not supported by
ARCore”

Under the voice “Other Settings” = “Rendering” change the Graphics APl and remove Vulkan.

If you can not find Vulkan in Rendering: In BuildSettings -> Project settings -> Player -> Other settings: disable the
Auto Graphics APl checkbox and remove Vulcan from the Graphics APIs list
https://forum.unity.com/threads/you-have-enabled-the-vulkan-graphics-api-which-is-not-supported-by-
arcore.896741/
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