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GET STARTED WITH ARFOUNDATION

AR foundation allows to work with different AR platforms inside Unity3D

You can install ARFoundation in Unity’s Package Manager
In addition to that Package, you should install also the Plugin you need, as ARKit for
|OS apps or ARCore for Android apps development.

Supported Platform Packages
The following platform packages and later implement the AR Foundation features indicated above:

Package Name

Version
ARCore XR Plugin 4.1
ARKit XR Plugin 4.1
ARKit Face Tracking 4.1
Magic Leap XR Plugin 6.0 .,
Windows XR Plugin 5.0 J i

https://docs.unity3d.com/Packages/com.unity.xr.arfoundation@4. | /manual/index.html#using-ar-foundation
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WHAT TO DO NOW

At this point we have modeled a Solar System in a Unity 3D Scene named
SampleScene.

Now we will use the same assets to create the XR version, then we will build it
for 1OS with ARKit + ARFoundation
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CREATE A NEW SCENE

Create a new scene: File > New Scene , save it and + v [ Al Shaded
call it SampleSceneAR > < SampleSceneAR s

) Main Camera Set Active Scene

W# venus

. . 4@ uranus Save Scene

Go to Assets folder and right click on the » G satum S
SampleScene -> select Open Scene Additive @ neptune N

W@ mercury Save

W@ mars

& sun Unload Scene
From the SampleScene, copy all the planets Game Objects 'E,: g Remove Scene
and the SetupScene Game Object &) Directional Light

t
> % gznuvpasscene Select Scene Asset

0 EventSystem
Right click on the SampleScene -> select Unload Scene

Paste the Game Objects in the SampleSceneAR

Right click on the SampleScene -> select Remove Scene

Add New Scene

GameObject




ADD ARFOUNDATION PACKAGE

Go to Window > Package Manager

In the Package Manager select “Packages: Unity Registry” then
search the term AR

Install ARFoundation

Install ARKit or ARCore, depending on your target device (for this
exercise we will install ARKit)




SETUP THE SampleSceneAR

Now in the SampleSceneAR delete
the Main Camera

Add a GameObject > XR > AR
Session

AR Session supports enabling and
disabling XR on the target device

Add a GameObject > XR > AR
Origin

Because AR devices provide their
data in "session space", which is an
unscaled space relative to the
beginning of the AR session,

the ARSessionOrigin performs the
appropriate transformation into
Unity space

Hierarchy

v | All

& SampleSceneAR
P Directional Light
@ sun
@ neptune
4@ venus

> @ saturn
4@ mercury
E” earth
N# mars
4@ jupiter
4@ uranus
0 SetupScene
0 AR Session

» ) AR Session Origin

# Scene | @® Game

1™\ shaded

SIECICIETE

2
A

20| |~

[ TR 4 lGizmos |

Save Scene

Save Scene As

Select Scene Asset
Add New Scene

GameObject

Project | E Console

>

v

Create Empty
3D Object
Effects

Light

Audio

Video

ul

XR

Camera

v VvV VvV VvV VvV VvV Vv

| Convert Main Camera To XR Rig

AR Session Origin

AR Session
AR Default Point Cloud

v Favorites
O, All Materials
O, All Models
O, All Prefabs

Assets > Scenes

Vo W

AR Default Plane
AR Default Face




BUILD SETUP

Go to File > Build Settings

Click on the button “Add Open Scenes”

Click on the target device iOS and then

click on the button “Switch Platform,” wait M

for Unity to switch
(it may take some minutes)

Now in the Build Settings click on the
button “Player Settings” to open the
corresponding panel

Build Settings

Build Settings

Scenes In Build

v Scenes/SampleSceneAR

Platform

@ PC, Mac & Linux Standalone €}

\-}3 ﬁ. Android

E WebGL

tvOS tvOS
=ra PS4

l;\ Xbox One

\ Player Settings...

\B—'ﬁl

\ Add Open Scenes

108S ios
Run in Xcode v.12.4 / Applications /X v
Run in Xcode as Release v

Symlink Unity libraries
Development Build

Autoconnect Profiler
Deep Profiling
Script Debugging
Scripts Only Build

Compression Method Default v

\ blﬁut Unity Cloud Build

SW|tch Platform Build And Run

https://docs.unity3d.com/Packages/com.unity.xr.arfoundation@4. | /manual/index.html#using-ar-foundation
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PLAYER SETTINGS SETUP

In the Player Settings click on iOS

under the voice “Other Settings” = “Configuration” check the box
corresponding to “Requires ARKit support”

( Player Settings are inside the Project Settings window, you can also go to Player
Settings by click on Edit > Project Settings then click on “Player” )
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i | @ ) [sccount <[ tayers < [[Layow -

£ Project Settings

Adaptive Performance Player
Audio
Editor Default Cursor
Graphics
Input Manager
Package Manager
Physics Cursor Hotspot X 0 YO0 S . .
Physica 20 _ crolling down with the mouse
Player & e | L] I
Preset Manager . .
Tl Settings foriOS
Scene Template [ » Icon ’
Script Execution Order ) .
v Services [ » Resolution and Presentation ’ | ©@ Inspector | & Project Settings
Ads (
. » Splash ]
Analytics ‘ e —— Adaptive Performance Player 9 i+
Cloud Buil a . i e
Clgﬂd Dlijeln:nostics ‘ > Debugging and crash reporting ] 2:::3 iOS Provisioning Pro Browse |
Collaborate v Other Settings Graphics Profile ID:
Talgns-:zz E:;cel::smg Rendering g::iahgaen;girager Profile Type: Automatic v
TextMesh Pro Color Space* Gamina M Physics Configuration
Time  Color Gamut* | IPlinses A0 Scripting Backend IL2CPP v
Timeline — sRGB Api Compatibility Level* NET Standard 2.0 =
Version Control L Preset Manager C++ Compiler Confi i Rel M
v XR Plug-in Management - Quality ++ Compiler Configuration _e ease
ARKit Metal API Validation* (v] chne Templ.ate Use incremental GC v
Metal Write-Only Backbuffer m . gz:zzzec“m" Order Camera Usage Description* Required for augmented reality support.
15 L U P — Ads Microphone Usage Description*
Analytics Location Usage Description* -
Cloud Build Use on-demand resources*
Cloud Diagnostics Accelerometer Frequency* 60 Hz v
CellIaEE . Mute Other Audio Sources* [ ]
In-App Purchasing
Tags and Layers A Audio input from Bluetooth microphones is not supported when Mute Other Audio Sources
TextMesh Pro is(off:
Pmel' Prepare iOS for Recording [ ]
imeline . .
] Force iOS Speakers when Recording L
¥ XR Plug-in Management Requires Persistent WiFi* L
ARKit Allow downloads over HTTP (nonsecure)* v
» Supported URL schemes*
Target Device iPhone + iPad v
Target SDK Device SDK v
Target minimum iOS Version 11.0
Enable ProMotion Support [ ]
0 Requires ARKit support v
L .
» Defer system gestures on edges
Hide home button on iPhone X [ ]
Render Extra Frame on Pause [ ]
Enable Custom Background Behaviors
Architecture ARM64 v
Active Input Handling* Input Manager (Old) v
Script Compilation
[ [ e e N B N £ PP e PR ]




XR PLUGIN MANAGEMENT SETUP

| @ Inspector | % Project Settings |

Q
Adaptive Performance XR Plug-in Management 7_1
Audio

0S ( iy

Now in the Project Settings click on Edtor - |
raphics i
(13 o bRl
XR Plug-in Management r:g&x:nﬁgi;ger Initialize XR on Startup v

. . . . Physics i :

Click on iOS (or Android depending on  physics2p Ao
o g . . Player v ARKit

target device, in this exercise we are Preset Manager K 7 %

5 3 Quality
using |OS) Scene Template

Script Execution Order Information about configuration, tracking and migration can be found below.
i i Servi View D tati
Enable the Provider Plugin setup, e B
o . . Analyti
checking the box ARKit for iOS SR
. Cloud Di i

(ARCore for Android) Cpanosies

In-App Purchasing
Tags and Layers

https://docs.unity3d.com/Packages/com.
unity.xr.arfoundation@4. | /manual/inde TextMiesn Pro
x.html#provider-plugin-setup ~ Timeline

Version Control

XR Plug-in Management

7’\ ARKit

https://docs.unity3d.com/Packages/com.unity.xr.arfoundation(@4. | /manual/index.html#using-ar-foundation
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BUILD THE PROJECT

(Optional) Before building the project in the :S'T:.g” e
Player Settings under the voice “Other Settings” TScenes/SamiesconeAR C
- “ldentification” you can change the Bundle
|dentifier, that should be a unique identifier of
your project. o e
Now you can go to Build Settings and click on bbbl L

iOS i0s 0N Runin Xcode v.12.4 / Applications /X ¥

Bu i I d lﬁl ol Run in Xcode as

Symlink Unity libraries

% WebGL Development Buil'd
Autoconnect Profiler
wvOS tvOS Deep Profiling
Script Debugging
=ra PS4 Scripts Only Build

l;\ Xbox One

Compression Method

Player Settings...

Release M

Default v

Learn about Unity Cloud Build

Build Build And Run

] ——

g}l

https://docs.unity3d.com/Packages/com.unity.xr.arfoundation@4. | /manual/index.html#using-ar-foundation
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BUILD THE PROJECT

mv Ev mw
Now a Save Panel appears, create a folder called S—

Builds inside the root folder called “exe-solar-sys” 5 exe-solar-sys s
and inside it create another folder, we will call it Previous 7 Days

<

“version0” :
this folder will be the one to be opened with Xcode.

New Folder

-—

f—

[—

I BEREEENSI

Build iOS

Today

Builds
Temp

Yesterday

Assets

Library

Logs

obj

Packages
ProjectSettings
UserSettinas

vV v v v v

Cancel
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ANDROID

OFF TOPIC: IF YOU WANT TO BUILD WITH

Build Settings

Build Settings

With Unity targeting an Android, you can press the e
button Build to directly create the .apk to be installed
into your mobile device.

Otherwise, you can decide to export it as Gradle

Platform

Project. L) Pc, Mac & Linux Standalone
0S 10
|ﬁ| Android %
This second option is very similar to the step 26 : B wese
you need to create a Builds folder and then another | wos
folder as versionO inside it, and the versionO folder mra PSS
will be the one you will need to open with Android fa) XboxOne

Studio.

Player Settings...

Add Open Scenes

|ﬁ| Android

Texture Compression Don't override
ETC2 fallback 32-bit v
Export Project

Symlink Sources

Build App Bundle (Google Play

Create symbols.zip

Run Device Default device v = Refresh

Development Build
Autoconnect Profiler
Deep Profiling

Script Debugging
Scripts Only Build Patch  Patch And Run
Compression Method Lz4 v

Learn about Unity Cloud Build

Export Build And Run

y

https://docs.unity3d.com/Packages/com.unity.xr.arfoundation(@4. | /manual/index.html#using-ar-foundation
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XCODE FOR IOS

To build an Xcode project for development you need a simple Apple ID (it is the
free personal ID you use to login in the smartphone or on iCloud)
https://support.apple.com/it-it/apple-id

The free Apple ID can be used only to build TEST APP on your iOS device, it
cannot be used to load on Apple Store (it needs a billing account)

To build the TEST app on the iOS target device remember that:
the Apple ID on Xcode should be the same ID on the iOS device

on the iOS device you can install no more than 3 different TEST apps



https://support.apple.com/it-it/apple-id

XCODE FOR IOS

® [ ] Accoun! ts

Once the build has done you can open the version0O folder 5 @ & © H o o o
with Xcode

uAppIeID
In the menu click on Xcode > Preferences _ De;‘if;'ilfi-

Click on Accounts area and click on +

O Download Manual Profiles Manage Certificates...

Select the type of account you would like to add:

5l Xcode Server

o 5 JC itbucket Cloud
From the popup choose Apple ID, then click on Confirm and () Bibuckere

perform the login with your Apple ID credentials

jof| Bitbucket Server

Cancel Continue




XCODE FOR IOS

Now click on the Root of the
Project (the one usually called
Unity-iPhone)

Click on “Signing & Capabilities”

check the box “Automatically
manage signing” a popup will
appear, click on the button
“Enable Automatic”

Now at the voice Team, click on
“none’”’, and from the menu
select your ID

@ Xcode File Edit View Find

Navigate Editor Product Debug Source Control Window Help

eoe [ | 2

v B Unity-iPhone

<

<

Unity-iPhone > . iPad di Aislab Indexing | Processing files

B R QA O g D B B <

E| Unity-iPhone

Unity-iPhone.xcodeproj

v {3 Data [D General Signing & Capabilities Resource Tags Info Build Settings Build Phases
& boot.config PROJECT + Capability m Release rProfiling rRunning  Debug
k&l globalgamemanagers

Q Unity-iPhone -
L& globalgamemanagers.assets Signing
TARGETS

i levelO Automatically manage signing
> £ Managed Unity—iPhone
> 0 Resources ("] Unity-iPhone Tests

. e e . Te N
6 RuntimelnitializeOnLoads.js... £33 UnityFramework eam one
6 ScriptingAssemblies.json Bundle Idenid 'm.DefaultCompany.exe-solar-sys

sharedassets0.assets

Provisiong# Profile Xcode Managed Profile

sharedassets0.assets.resS Certificate Apple Development
k&l unity default resources

> 3 UnitySubsystems Status @ Signing for "Unity-iPhone" requires a

development team.
& Images.xcassets P

7~ MainApp Capabilities editor.
m main.mm

7 Classes

> 77 PluginBase

>@ i

> 77 Unity

CrashReporter.h

CrashReporter.mm

iPhone_Sensors.h

iPhone_Sensors.mm

main.mm

PLCrashReporter.h

" Prefix.pch

= (3 [ [ [3 (=

UndefinePlatforms.h
RedefinePlatforms.h
Preprocessor.h
UnityAppController.h
UnityAppController.mm
UnityAppController+Render...

ERERERE RE-NERE

UnityAppController+Render...
= o8 + - (@

Select a development team in the Signing &

Build Rules

<

1D
>

B © O
Identity and Type
Name Unity-iPhone
Location
-
)
Project Document E
Project Format  Xcode 3.2-compatible | in
Organization
Class Prefix F
Text Settings
Indent Using  Spaces (<]
Widths 4l 4l
Tab Indent
Wrap lines
3




XCODE FOR IOS

Now connect your device, it
should automatically appear.
(If it does not appear
automatically you can click on
“Any Device” to open the
menu and see the available
devices, sometimes if the device
IS not appearing you can just
unplug it, unlock the device and
then plug it again)

Now you can Run it

Xcode File Edit View Find

Navigate

Editor

Source Control

Window  Help

boot.config

| €]
L globalgamemaygh

k& levelo

> [ Managed

3 Resourceg
) imegfitializeOnLoads.js...
ScriptiffgAssemblies.json
sharggfassets0.assets
edassets0.assets.resS

ity default resources

MainApp
m main.mm

" Classes

~ PluginBase
>l

> 77 Unity
CrashReporter.h

]
-
v

h

m CrashReporter.mm

h iPhone_Sensors.h

m iPhone_Sensors.mm
m main.mm

h PLCrashReporter.h

* Prefix.pch
UndefinePlatforms.h
RedefinePlatforms.h
Preprocessor.h
UnityAppController.h
UnityAppController.mm
UnityAppController+Render...

v
ERERERERENERE"

UnityAppController+Render...
Q- o8

B8 <
Unity-iPhone

O

Unity-iPhone ) [l iPad di Aislab

PROJECT
& unity-iPhone
TARGETS

Unity-iPhone
(7] Unity-iPhone Tests
ié—] UnityFramework

Indexing | Processing files

By Unity-iPhone.xcodeproj

General Signing & Capabilities

+ Capability m Release

Resource Tags Info Build Settings Build Phases

Team
Bundle Identifier
Provisioning Profile

Signing Certificate

Status

rProfiling ! rRunning  Debug

Automatically manage signing

None
com.DefaultCompany.exe-solar-sys
Xcode Managed Profile
Apple Development
© Signing for "Unity-iPhone" requires a
development team.

Select a development team in the Signing &
Capabilities editor.

Build Rules

E © 0O

Identity and Type

Name Unity-iPhone

Location

Project Document

Project Format  Xcode 3.2-compatible @ n

Organization

Class Prefix

Text Settings

Indent Using Spaces

Widths 4

Tab

Wrap lines

I

o @

4
Indent
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TROUBLESHOOTING

[iOS / Android] If after the build, you run it on your device and the screen is
black:

you should enable the Provider Plugin setup, in the “Project Settings” click on
“XR Plug-in Management” then click on iOS or on Android and respectively
check the box ARKit or ARCore ( step | 1)

[Android] If after the build you get an error on ARCore as
“BuildFailedException: ARCore Required apps require a minimum SDK version
of 24.* or “Failed getting available Android API levels. Could not find Android
SDK Tools.”

You can solve it: Project Settings > Player Settings > Android, under the voice
“Other Settings” = “ldentification” change the “Minimum API Level” to
Nougat level 24

[Android] “BuildFailedException: You have enabled the Vulkan graphics API,
which is not supported by ARCore.”

Under the voice “Other Settings” = “Rendering” change the Graphics APl and
remove Vulkan




